Difference between revisions of "Sprite:setShader"

(remove language stuff)
 
(7 intermediate revisions by 2 users not shown)
Line 1: Line 1:
 
__NOTOC__
 
__NOTOC__
 
'''Available since:''' Gideros 2015.06.30<br/>
 
'''Available since:''' Gideros 2015.06.30<br/>
 +
'''Class:''' [[Sprite]]<br/>
 +
 
=== Description ===
 
=== Description ===
Set shader for this sprite. If nil is provided, sets default shader for current object
+
Sets a shader for this sprite. If nil is provided, sets default shader for the current object.
 
<source lang="lua">
 
<source lang="lua">
Sprite:setShader(shader)
+
Sprite:setShader(shader,programType,programVariant,inherit)
 
</source>
 
</source>
 +
 
=== Parameters ===
 
=== Parameters ===
'''shader''': (Shader) shader to use for this object <br/>
+
'''shader''': (Shader) shader to use for this object<br/>
 +
'''programType''': (int) the type of program this shader should replace. Use nil for any '''optional'''<br/>
 +
'''programVariant''': (int) the variant of program this shader should replace '''optional'''<br/>
 +
'''inherit''': (boolean) this shader should be used for sub-sprite too '''optional'''<br/>
 +
 
 +
{{Sprite}}

Latest revision as of 23:22, 2 February 2021

Available since: Gideros 2015.06.30
Class: Sprite

Description

Sets a shader for this sprite. If nil is provided, sets default shader for the current object.

Sprite:setShader(shader,programType,programVariant,inherit)

Parameters

shader: (Shader) shader to use for this object
programType: (int) the type of program this shader should replace. Use nil for any optional
programVariant: (int) the variant of program this shader should replace optional
inherit: (boolean) this shader should be used for sub-sprite too optional